GitHub Advisoryadvisory · Maven, PyPI

GHSA-6vvc-c2m3-cjf3 JGit Improper Input Validation vulnerability

CRITICAL Published 2022-05-17 Modified 2024-09-25 Official page ↗
Aliases
CVE-2014-9390
Ecosystem
Maven, PyPI
Packages
org.eclipse.jgit:org.eclipse.jgit, mercurial
Severity
Critical
CVSS vector
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
Weaknesses
CWE-20
Reviewed
2023-01-26

Affected packages

• Maven org.eclipse.jgit:org.eclipse.jgit: < 3.5.3 → fixed in 3.5.3 • PyPI mercurial: < 3.2.3 → fixed in 3.2.3

Description

Git before 1.8.5.6, 1.9.x before 1.9.5, 2.0.x before 2.0.5, 2.1.x before 2.1.4, and 2.2.x before 2.2.1 on Windows and OS X; Mercurial before 3.2.3 on Windows and OS X; Apple Xcode before 6.2 beta 3; mine; libgit2; Egit; and JGit allow remote Git servers to execute arbitrary commands via a tree containing a crafted .git/config file with (1) an ignorable Unicode codepoint, (2) a git~1/config representation, or (3) mixed case that is improperly handled on a case-insensitive filesystem.

Related

Alias · CVE (1)

  • CVE-2014-9390 Git before 1.8.5.6, 1.9.x before 1.9.5, 2.0.x before 2.0.5, 2.1.x before 2.1.4, and 2.2.x before 2.2.1 on Windows and OS X; Mercurial… vulnerability

Weakness · CWE (1)

  • CWE-20 Improper Input Validation weakness

References