GitHub Advisoryadvisory · npm
GHSA-6vwx-mwp8-fh44 Cross-site Scripting in reveal.js
MEDIUM
Official page ↗
- Aliases
- CVE-2020-8127
- Ecosystem
- npm
- Packages
- reveal.js
- Severity
- Moderate
- CVSS vector
- CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N
- Weaknesses
- CWE-79
- Reviewed
- 2021-04-20
Affected packages
• npm reveal.js: < 3.9.2 → fixed in 3.9.2
Description
Insufficient validation in cross-origin communication (postMessage) in reveal.js version 3.9.1 and earlier allow attackers to perform cross-site scripting attacks.
Related
Alias · CVE (1)
- CVE-2020-8127 Insufficient validation in cross-origin communication (postMessage) in reveal.js version 3.9.1 and earlier allow attackers to perform… vulnerability
Weakness · CWE (1)
- CWE-79 Improper Neutralization of Input During Web Page Generation weakness