GitHub Advisoryadvisory · npm
GHSA-6vx4-v2jw-qwqh Trix editor subject to XSS vulnerabilities on copy & paste
MEDIUM
Official page ↗
- Aliases
- CVE-2024-53847
- Ecosystem
- npm
- Packages
- trix
- Severity
- Moderate
- CVSS vector
- CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:A/VC:N/VI:N/VA:N/SC:L/SI:L/SA:N
- Weaknesses
- CWE-79
- Reviewed
- 2024-12-09
Affected packages
• npm trix: >= 2.0.0, < 2.1.9 → fixed in 2.1.9
• npm trix: >= 1.0.0, < 1.3.3 → fixed in 1.3.3
Description
The Trix editor, in versions prior to 2.1.9 and 1.3.3, is vulnerable to XSS + mutation XSS attacks when pasting malicious code.
Impact
An attacker could trick a user to copy and paste malicious code that would execute arbitrary JavaScript code within the context of the user's session, potentially leading to unauthorized actions being performed or sensitive information being disclosed.
Patches
Update Recommendation: Users should upgrade to Trix editor version 2.1.9 or later, which uses DOMPurify to sanitize the pasted content.
If using Trix 1.x, upgrade to version 1.3.3 or later.
Mitigations
This is not really a workaround but something that should be considered in addition to upgrading to the patched version. If affected users can disallow browsers that don't support a Content Security Policy, then this would be an effective workaround for this and all XSS vulnerabilities. Set CSP policies such as script-src 'self' to ensure that only scripts hosted on the same origin are executed, and explicitly prohibit inline scripts using script-src-elem.
References
The XSS vulnerability was reported by HackerOne researcher hiumee.
The mutation XSS vulnerability was reported by HackerOne researcher sudi.
Related
Alias · CVE (1)
- CVE-2024-53847 The Trix rich text editor, prior to versions 2.1.9 and 1.3.3, is vulnerable to cross-site scripting (XSS) + mutation XSS attacks when… vulnerability
Weakness · CWE (1)
- CWE-79 Improper Neutralization of Input During Web Page Generation weakness