GitHub Advisoryadvisory · Maven
GHSA-6w3h-vq7m-v3qf Jenkins Black Duck Detect Plugin information exposure vulnerability
MEDIUM
Official page ↗
- Aliases
- CVE-2018-1000191
- Ecosystem
- Maven
- Packages
- com.synopsys.integration:synopsys-detect
- Severity
- Moderate
- CVSS vector
- CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:N/A:N
- Weaknesses
- CWE-200
- Reviewed
- 2024-01-05
Affected packages
• Maven com.synopsys.integration:synopsys-detect: < 1.4.1 → fixed in 1.4.1
Description
Jenkins Black Duck Detect Plugin did not perform permission checks on methods implementing form validation. This allowed users with Overall/Read access to Jenkins to connect to an attacker-specified URL using attacker-specified credentials IDs obtained through another method, capturing credentials stored in Jenkins, and to cause Jenkins to submit HTTP requests to attacker-specified URLs.
Additionally, these form validation methods did not require POST requests, resulting in a CSRF vulnerability.
These form validation methods now require POST requests and Overall/Administer permissions.
Related
Alias · CVE (1)
- CVE-2018-1000191 A exposure of sensitive information vulnerability exists in Jenkins Black Duck Detect Plugin 1.4.0 and older in… vulnerability
Weakness · CWE (1)
- CWE-200 Exposure of Sensitive Information to an Unauthorized Actor weakness
References
- https://nvd.nist.gov/vuln/detail/CVE-2018-1000191 advisory
- https://github.com/jenkinsci/synopsys-detect-plugin/commit/0da415d793e39f2ed3ec0fec5955485904d7175b web
- https://github.com/jenkinsci/synopsys-detect-plugin web
- https://jenkins.io/security/advisory/2018-06-04/#SECURITY-866 web
- https://plugins.jenkins.io/blackduck-detect web