GitHub Advisoryadvisory · Maven

GHSA-6w48-2g9j-v9q5 Apache IoTDB has an Improper Input Validation vulnerability

CRITICAL Published 2026-03-09 Modified 2026-03-11 Official page ↗
Aliases
CVE-2026-24713
Ecosystem
Maven
Packages
org.apache.iotdb:iotdb-core
Severity
Critical
CVSS vector
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
Weaknesses
CWE-20, CWE-917
Reviewed
2026-03-11

Affected packages

• Maven org.apache.iotdb:iotdb-core: >= 1.0.0, < 1.3.7 → fixed in 1.3.7 • Maven org.apache.iotdb:iotdb-core: >= 2.0.0, < 2.0.7 → fixed in 2.0.7

Description

Improper Input Validation vulnerability in Apache IoTDB. This issue affects Apache IoTDB: from 1.0.0 before 1.3.7, from 2.0.0 before 2.0.7. Users are recommended to upgrade to version 1.3.7 or 2.0.7, which fixes the issue.

Related

Alias · CVE (1)

  • CVE-2026-24713 Improper Input Validation vulnerability in Apache IoTDB. vulnerability

Weakness · CWE (2)

  • CWE-20 Improper Input Validation weakness
  • CWE-917 Improper Neutralization of Special Elements used in an Expression Language Statement weakness

References