GitHub Advisoryadvisory · Packagist

GHSA-6wfj-2mw7-p5cg phpMyAdmin micro history Implementation XSS Vulnerability

MEDIUM Published 2022-05-14 Modified 2023-08-15 Official page ↗
Aliases
CVE-2014-6300
Ecosystem
Packagist
Packages
phpmyadmin/phpmyadmin
Severity
Moderate
Weaknesses
CWE-79
Reviewed
2023-08-15

Affected packages

• Packagist phpmyadmin/phpmyadmin: >= 4.0.0, < 4.0.10.3 → fixed in 4.0.10.3 • Packagist phpmyadmin/phpmyadmin: >= 4.1.0, < 4.1.14.4 → fixed in 4.1.14.4 • Packagist phpmyadmin/phpmyadmin: >= 4.2.0, < 4.2.8.1 → fixed in 4.2.8.1

Description

Cross-site scripting (XSS) vulnerability in the micro history implementation in phpMyAdmin 4.0.x before 4.0.10.3, 4.1.x before 4.1.14.4, and 4.2.x before 4.2.8.1 allows remote attackers to inject arbitrary web script or HTML, and consequently conduct a cross-site request forgery (CSRF) attack to create a root account, via a crafted URL, related to js/ajax.js.

Related

Alias · CVE (1)

  • CVE-2014-6300 Cross-site scripting (XSS) vulnerability in the micro history implementation in phpMyAdmin 4.0.x before 4.0.10.3, 4.1.x before 4.1.14.4,… vulnerability

Weakness · CWE (1)

  • CWE-79 Improper Neutralization of Input During Web Page Generation weakness

References