GitHub Advisoryadvisory · Maven
GHSA-6wh8-mr6f-6cx2 Cross-site Scripting in Jenkins Application Detector Plugin
HIGH
Official page ↗
- Aliases
- CVE-2022-30960
- Ecosystem
- Maven
- Packages
- org.jenkins-ci.plugins:app-detector
- Severity
- High
- CVSS vector
- CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:U/C:H/I:H/A:H
- Weaknesses
- CWE-79
- Reviewed
- 2022-06-01
Affected packages
• Maven org.jenkins-ci.plugins:app-detector: < 1.0.9 → fixed in 1.0.9
Description
Jenkins Application Detector Plugin 1.0.8 and earlier does not escape the name of Chois Application Version parameters on views displaying parameters, resulting in a stored cross-site scripting (XSS) vulnerability exploitable by attackers with Item/Configure permission.
Related
Alias · CVE (1)
- CVE-2022-30960 Jenkins Application Detector Plugin 1.0.8 and earlier does not escape the name of Chois Application Version parameters on views displaying… vulnerability
Weakness · CWE (1)
- CWE-79 Improper Neutralization of Input During Web Page Generation weakness