GitHub Advisoryadvisory · Packagist
GHSA-6wjw-qf87-fv5v Laravel Encrypter Failure to decryption vulnerability
LOW
Official page ↗
- Ecosystem
- Packagist
- Packages
- illuminate/encryption
- Severity
- Low
- Weaknesses
- CWE-1240
- Reviewed
- 2024-05-15
Affected packages
• Packagist illuminate/encryption: >= 5.5.0, < 5.5.40 → fixed in 5.5.40
• Packagist illuminate/encryption: >= 5.6.0, < 5.6.15 → fixed in 5.6.15
Description
A potential exploit of the Laravel Encrypter component that may cause the Encrypter to fail on decryption and unexpectedly return false.
To exploit this, the attacker must be able to modify the encrypted payload before it is decrypted. Depending on the code within your application, this could lead to unexpected behavior when combined with weak type comparisons, for example:
```php
<?php
$decyptedValue = decrypt($secret);
if ($decryptedValue == '') {
// Code is run even though decrypted value is false...
}
```
Related
Weakness · CWE (1)
- CWE-1240 Use of a Cryptographic Primitive with a Risky Implementation weakness
References
- https://github.com/illuminate/encryption/commit/51667a52bd7d135c6aa40a897656ffe9d3cd072d web
- https://github.com/illuminate/encryption/commit/c80b1da6a0412bd74bd56dc80f6126f561631b05 web
- https://github.com/FriendsOfPHP/security-advisories/blob/master/illuminate/encryption/2018-03-30-1.yaml web
- https://github.com/illuminate/encryption package
- https://medium.com/@taylorotwell/laravel-security-release-5-6-15-and-5-5-40-56f1257933a0 web