GitHub Advisoryadvisory · RubyGems
GHSA-6wpv-cj6x-v3jw http vulnerable to Exposure of Sensitive Information to an Unauthorized Actor
MEDIUM
Official page ↗
- Aliases
- CVE-2015-1828
- Ecosystem
- RubyGems
- Packages
- http
- Severity
- Moderate
- CVSS vector
- CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:N/A:N
- Weaknesses
- CWE-200
- Reviewed
- 2020-06-16
Affected packages
• RubyGems http: >= 0.7.0, < 0.7.3 → fixed in 0.7.3
• RubyGems http: < 0.6.4 → fixed in 0.6.4
Description
The Ruby http gem before 0.6.4 and 0.7.3 does not verify hostnames in SSL connections, which might allow remote attackers to obtain sensitive information via a man-in-the-middle-attack.
Related
Alias · CVE (1)
- CVE-2015-1828 The Ruby http gem before 0.7.3 does not verify hostnames in SSL connections, which might allow remote attackers to obtain sensitive… vulnerability
Weakness · CWE (1)
- CWE-200 Exposure of Sensitive Information to an Unauthorized Actor weakness
References
- https://nvd.nist.gov/vuln/detail/CVE-2015-1828 advisory
- https://github.com/ruby/openssl/issues/8 web
- https://github.com/httprb/http package
- https://github.com/rubysec/ruby-advisory-db/blob/master/gems/http/CVE-2015-1828.yml web
- https://groups.google.com/forum/#!topic/httprb/jkb4oxwZjkU web
- https://my.diffend.io/gems/http/0.6.3/0.6.4 web
- https://my.diffend.io/gems/http/0.7.2/0.7.3 web
- https://rubysec.com/advisories/http-CVE-2015-1828 web