GitHub Advisoryadvisory · Packagist

GHSA-6wq7-cg9h-mj6q Magento Improper Access Control leads to Security feature bypass

MEDIUM Published 2025-04-08 Modified 2025-10-23 Official page ↗
Aliases
CVE-2025-27190
Ecosystem
Packagist
Packages
magento/project-community-edition, magento/community-edition
Severity
Moderate
CVSS vector
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:L/A:N
Weaknesses
CWE-284
Reviewed
2025-10-23

Affected packages

• Packagist magento/project-community-edition: <= 2.0.2 (no fix yet) • Packagist magento/community-edition: >= 2.4.7-beta1, < 2.4.7-p5 → fixed in 2.4.7-p5 • Packagist magento/community-edition: >= 2.4.6-p1, < 2.4.6-p10 → fixed in 2.4.6-p10 • Packagist magento/community-edition: >= 2.4.5-p1, < 2.4.5-p12 → fixed in 2.4.5-p12 • Packagist magento/community-edition: < 2.4.4-p13 → fixed in 2.4.4-p13 • Packagist magento/community-edition: >= 2.4.8-beta1, < 2.4.8-beta2 → fixed in 2.4.8-beta2 • Packagist magento/community-edition: 2.4.5 (no fix yet) • Packagist magento/community-edition: 2.4.4 (no fix yet) • Packagist magento/community-edition: 2.4.6 (no fix yet) • Packagist magento/community-edition: 2.4.7 (no fix yet)

Description

Magento versions 2.4.7-p4, 2.4.6-p9, 2.4.5-p11, 2.4.4-p12, 2.4.8-beta2 and earlier are affected by an Improper Access Control vulnerability that could result in a Security feature bypass. An attacker could leverage this vulnerability to bypass security measures and gain unauthorized access. Exploitation of this issue does not require user interaction.

Related

Alias · CVE (1)

  • CVE-2025-27190 Adobe Commerce versions 2.4.7-p4, 2.4.6-p9, 2.4.5-p11, 2.4.4-p12, 2.4.8-beta2 and earlier are affected by an Improper Access Control… vulnerability

Weakness · CWE (1)

  • CWE-284 Improper Access Control weakness

References