GitHub Advisoryadvisory · PyPI
GHSA-6wvf-77m9-58rm LiteLLM vulnerable to server-side template injection in the /prompts/test endpoint
CRITICAL
Official page ↗
- Aliases
- CVE-2026-37004
- Ecosystem
- PyPI
- Packages
- litellm
- Severity
- Critical
- CVSS vector
- CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
- Weaknesses
- CWE-1336
- Reviewed
- 2026-09-08
Affected packages
• PyPI litellm: < 1.83.7 → fixed in 1.83.7
Description
BerriAI litellm <=1.82.4 is vulnerable to Server-Side Template Injection (SSTI), which allows unauthenticated remote attackers to execute arbitrary OS commands via a crafted dotprompt_content parameter in the /prompts/test endpoint due to use of an unsandboxed jinja2.Environment.
Related
Alias · CVE (1)
- CVE-2026-37004 BerriAI litellm <=1.82.4 is vulnerable to Server-Side Template Injection (SSTI), which allows unauthenticated remote attackers to execute… vulnerability
Weakness · CWE (1)
- CWE-1336 Improper Neutralization of Special Elements Used in a Template Engine weakness
References
- https://nvd.nist.gov/vuln/detail/CVE-2026-37004 advisory
- https://github.com/BerriAI/litellm/commit/d910a95661fce3cdd36f3b06c03ecf9c46c6457c web
- https://github.com/BerriAI/litellm package
- https://github.com/BerriAI/litellm/blob/244bdffd1bfe7bebdfdef516e1ebe426a898e2f0/litellm/proxy/prompts/prompt_endpoints.py#L1073 web
- https://github.com/BerriAI/litellm/releases/tag/v1.83.7-stable web
- https://yerangamage.com/cves/detail/?slug=litellm-ssti-rce web