GitHub Advisoryadvisory · PyPI
GHSA-6x4h-9622-fqr6 Improper validation in meraki
HIGH
Official page ↗
- Ecosystem
- PyPI
- Packages
- meraki
- Severity
- High
- CVSS vector
- CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:L/I:L/A:N
- Reviewed
- 2023-12-13
Affected packages
• PyPI meraki: < 1.40.1 → fixed in 1.40.1
Description
aiohttp is an asynchronous HTTP client/server framework for asyncio and Python. Improper validation made it possible for an attacker to modify the HTTP request (e.g. to insert a new header) or create a new HTTP request if the attacker controls the HTTP version. The vulnerability only occurs if the attacker can control the HTTP version of the request. This issue has been patched in version 3.9.0.
meraki from version 1.40.1 requires aiohttp 3.9.0