GitHub Advisoryadvisory · Maven

GHSA-6x9x-8qw9-9pp6 Jetty vulnerable to authorization bypass due to inconsistent HTTP request handling (HTTP Request Smuggling)

CRITICAL Published 2018-10-19 Modified 2022-09-14 Official page ↗
Aliases
CVE-2017-7658
Ecosystem
Maven
Packages
org.eclipse.jetty:jetty-server
Severity
Critical
CVSS vector
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
Weaknesses
CWE-444
Reviewed
2020-06-16

Affected packages

• Maven org.eclipse.jetty:jetty-server: < 9.2.25.v20180606 → fixed in 9.2.25.v20180606 • Maven org.eclipse.jetty:jetty-server: >= 9.3.0, < 9.3.24.v20180605 → fixed in 9.3.24.v20180605 • Maven org.eclipse.jetty:jetty-server: >= 9.4.0, < 9.4.11.v20180605 → fixed in 9.4.11.v20180605

Description

Eclipse Jetty Server versions 9.2.x and older, 9.3.x (all non HTTP/1.x configurations), and 9.4.x (all HTTP/1.x configurations), are vulnerable to HTTP Request Smuggling when presented with two content-lengths headers, allowing authorization bypass. When presented with a content-length and a chunked encoding header, the content-length was ignored (as per RFC 2616). If an intermediary decides on the shorter length, but still passes on the longer body, then body content could be interpreted by Jetty as a pipelined request. If the intermediary is imposing authorization, the fake pipelined request bypasses that authorization.

Related

Alias · CVE (1)

  • CVE-2017-7658 In Eclipse Jetty Server, versions 9.2.x and older, 9.3.x (all non HTTP/1.x configurations), and 9.4.x (all HTTP/1.x configurations), when… vulnerability

Weakness · CWE (1)

  • CWE-444 Inconsistent Interpretation of HTTP Requests weakness

References