GitHub Advisoryadvisory · Maven
GHSA-6xhf-xx3j-75f5 Incorrect Authorization in Jenkins requests-plugin
MEDIUM
Official page ↗
- Aliases
- CVE-2022-34782
- Ecosystem
- Maven
- Packages
- org.jenkins-ci.plugins:requests
- Severity
- Moderate
- CVSS vector
- CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:N/A:N
- Weaknesses
- CWE-863
- Reviewed
- 2022-07-12
Affected packages
• Maven org.jenkins-ci.plugins:requests: < 2.2.17 → fixed in 2.2.17
Description
An incorrect permission check in Jenkins requests-plugin Plugin 2.2.16 and earlier allows attackers with Overall/Read permission to view the list of pending requests. requests-plugin Plugin 2.2.17 requires Overall/Administer permission to view the list of pending requests.
This is basically the same vulnerability as SECURITY-1995, whose fix was ineffective.
requests-plugin Plugin 2.2.17 requires Overall/Administer permission to view the list of pending requests.
Related
Alias · CVE (1)
- CVE-2022-34782 An incorrect permission check in Jenkins requests-plugin Plugin 2.2.16 and earlier allows attackers with Overall/Read permission to view… vulnerability
Weakness · CWE (1)
- CWE-863 Incorrect Authorization weakness