GitHub Advisoryadvisory · Go
GHSA-6xjj-v76v-fwpj Mattermost does not validate requesting user permissions before updating admin details
MEDIUM
Official page ↗
- Aliases
- CVE-2023-4107
- Ecosystem
- Go
- Packages
- github.com/mattermost/mattermost-server/v6
- Severity
- Moderate
- CVSS vector
- CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:H/I:H/A:L
- Weaknesses
- CWE-284, CWE-863
- Reviewed
- 2023-08-11
Affected packages
• Go github.com/mattermost/mattermost-server/v6: < 7.8.8 → fixed in 7.8.8
• Go github.com/mattermost/mattermost-server/v6: >= 7.9.0, < 7.9.6 → fixed in 7.9.6
• Go github.com/mattermost/mattermost-server/v6: >= 7.10.0, < 7.10.4 → fixed in 7.10.4
Description
Mattermost fails to properly validate the requesting user permissions when updating a system admin, allowing a user manager to update a system admin's details such as email, first name and last name.
Related
Alias · CVE (1)
- CVE-2023-4107 Mattermost fails to properly validate the requesting user permissions when updating a system admin, allowing a user manager to update a… vulnerability