GitHub Advisoryadvisory · Packagist

GHSA-6xpm-q8x9-j3rw Moodle allows attackers to bypass intended access restrictions

MEDIUM Published 2022-05-13 Modified 2024-01-26 Official page ↗
Aliases
CVE-2015-5342
Ecosystem
Packagist
Packages
moodle/moodle
Severity
Moderate
CVSS vector
CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:L/A:N
Reviewed
2024-01-26

Affected packages

• Packagist moodle/moodle: < 2.7.11 → fixed in 2.7.11 • Packagist moodle/moodle: >= 2.8.0, < 2.8.9 → fixed in 2.8.9 • Packagist moodle/moodle: >= 2.9.0, < 2.9.3 → fixed in 2.9.3

Description

The choice module in Moodle through 2.6.11, 2.7.x before 2.7.11, 2.8.x before 2.8.9, and 2.9.x before 2.9.3 allows remote authenticated users to bypass intended access restrictions by visiting a URL to add or delete responses in the closed state.

Related

Alias · CVE (1)

  • CVE-2015-5342 The choice module in Moodle through 2.6.11, 2.7.x before 2.7.11, 2.8.x before 2.8.9, and 2.9.x before 2.9.3 allows remote authenticated… vulnerability

References