GitHub Advisoryadvisory · Packagist

GHSA-6xqg-f34f-5fjx Moodle vulnerable to Cross-site Scripting

LOW Published 2022-05-13 Modified 2025-04-12 Official page ↗
Aliases
CVE-2011-4282
Ecosystem
Packagist
Packages
moodle/moodle
Severity
Low
CVSS vector
CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:P/VC:N/VI:N/VA:N/SC:L/SI:L/SA:N/E:U
Weaknesses
CWE-79
Reviewed
2025-04-12

Affected packages

• Packagist moodle/moodle: >= 2.0.0, < 2.0.2 → fixed in 2.0.2

Description

Multiple cross-site scripting (XSS) vulnerabilities in the course-tags functionality in tag/coursetags_more.php in Moodle 2.0.x before 2.0.2 allow remote attackers to inject arbitrary web script or HTML via the (1) sort or (2) show parameter.

Related

Alias · CVE (1)

  • CVE-2011-4282 Multiple cross-site scripting (XSS) vulnerabilities in the course-tags functionality in tag/coursetags_more.php in Moodle 2.0.x before… vulnerability

Weakness · CWE (1)

  • CWE-79 Improper Neutralization of Input During Web Page Generation weakness

References