GitHub Advisoryadvisory · Maven
GHSA-6xw9-qq9h-cr68 Jenkins Dynatrace Plugin vulnerable to Insufficiently Protected Credentials
HIGH
Official page ↗
- Aliases
- CVE-2019-10461
- Ecosystem
- Maven
- Packages
- org.jenkins-ci.plugins:dynatrace-dashboard
- Severity
- High
- CVSS vector
- CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
- Weaknesses
- CWE-522
- Reviewed
- 2022-12-06
Affected packages
• Maven org.jenkins-ci.plugins:dynatrace-dashboard: < 2.1.4 → fixed in 2.1.4
Description
Jenkins Dynatrace Application Monitoring Plugin prior to 2.1.4 stores credentials unencrypted in its global configuration file on the Jenkins master where they could be viewed by users with access to the master file system.
NOTE: This plugin is marked as DEPRECATED
Related
Alias · CVE (1)
- CVE-2019-10461 Jenkins Dynatrace Application Monitoring Plugin 2.1.3 and earlier stored credentials unencrypted in its global configuration file on the… vulnerability
Weakness · CWE (1)
- CWE-522 Insufficiently Protected Credentials weakness