GitHub Advisoryadvisory · RubyGems

GHSA-6xxq-j39w-g3f6 Puppet Arbitrary Command Execution

MEDIUM Published 2022-05-14 Modified 2024-01-12 Official page ↗
Aliases
CVE-2012-1988
Ecosystem
RubyGems
Packages
puppet
Severity
Moderate
Weaknesses
CWE-77, CWE-78
Reviewed
2024-01-12

Affected packages

• RubyGems puppet: >= 2.6.0, < 2.6.15 → fixed in 2.6.15 • RubyGems puppet: >= 2.7.0, < 2.7.13 → fixed in 2.7.13

Description

Puppet 2.6.x before 2.6.15 and 2.7.x before 2.7.13, and Puppet Enterprise (PE) Users 1.0, 1.1, 1.2.x, 2.0.x, and 2.5.x before 2.5.1 allows remote authenticated users with agent SSL keys and file-creation permissions on the puppet master to execute arbitrary commands by creating a file whose full pathname contains shell metacharacters, then performing a filebucket request.

Related

Alias · CVE (1)

  • CVE-2012-1988 Puppet 2.6.x before 2.6.15 and 2.7.x before 2.7.13, and Puppet Enterprise (PE) Users 1.0, 1.1, 1.2.x, 2.0.x, and 2.5.x before 2.5.1 allows… vulnerability

Weakness · CWE (2)

  • CWE-77 Improper Neutralization of Special Elements used in a Command weakness
  • CWE-78 Improper Neutralization of Special Elements used in an OS Command weakness

References