GitHub Advisoryadvisory · Maven
GHSA-723p-9rcj-xv8j RCE vulnerability in RadarGun Plugin
HIGH
Official page ↗
- Aliases
- CVE-2020-2123
- Ecosystem
- Maven
- Packages
- org.jenkins-ci.plugins:radargun
- Severity
- High
- CVSS vector
- CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
- Weaknesses
- CWE-502
- Reviewed
- 2023-01-14
Affected packages
• Maven org.jenkins-ci.plugins:radargun: < 1.8 → fixed in 1.8
Description
RadarGun Plugin 1.7 and earlier does not configure its YAML parser to prevent the instantiation of arbitrary types. This results in a remote code execution vulnerability exploitable by users able to configure RadarGun Plugin’s build step.
RadarGun Plugin 1.8 configures its YAML parser to only instantiate safe types.
Related
Alias · CVE (1)
- CVE-2020-2123 Jenkins RadarGun Plugin 1.7 and earlier does not configure its YAML parser to prevent the instantiation of arbitrary types, resulting in a… vulnerability
Weakness · CWE (1)
- CWE-502 Deserialization of Untrusted Data weakness
References
- https://nvd.nist.gov/vuln/detail/CVE-2020-2123 advisory
- https://github.com/jenkinsci/radargun-plugin/commit/63aba3b31d1a8ea140f26923eb48a25ef7f87e87 web
- https://github.com/jenkinsci/radargun-plugin package
- https://jenkins.io/security/advisory/2020-02-12/#SECURITY-1733 web
- http://www.openwall.com/lists/oss-security/2020/02/12/3 web