GitHub Advisoryadvisory · npm
GHSA-72gw-mp4g-v24j Multer vulnerable to Denial of Service via deeply nested field names
HIGH
Official page ↗
- Aliases
- CVE-2026-5079
- Ecosystem
- npm
- Packages
- multer
- Severity
- High
- CVSS vector
- CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
- Weaknesses
- CWE-400
- Reviewed
- 2026-06-17
Affected packages
• npm multer: >= 1.0.0, < 2.2.0 → fixed in 2.2.0
• npm multer: >= 3.0.0-alpha.1, < 3.0.0-alpha.2 → fixed in 3.0.0-alpha.2
Description
Impact
Multer is vulnerable to a Denial of Service (DoS) via deeply nested field names in multipart form data. The `append-field` dependency parses bracket notation in field names (e.g., `a[b][c]`) with no limit on nesting depth, allowing an attacker to force allocation of deeply nested object structures that consume CPU and memory. A single HTTP request with a crafted multipart body is sufficient to exploit this.
Patches
Users should upgrade to `2.2.0` and configure `limits.fieldNestingDepth` to the minimum depth their application requires.
Workarounds
Set `limits.fields` to a reasonable value to reduce the number of fields an attacker can send per request. This does not fully mitigate the issue but limits the impact.
Related
Alias · CVE (1)
- CVE-2026-5079 Impact: multer versions 1.0.0 through 2.1.1 and 3.0.0-alpha.1 are vulnerable to a Denial of Service via deeply nested field names in… vulnerability
Weakness · CWE (1)
- CWE-400 Uncontrolled Resource Consumption weakness