GitHub Advisoryadvisory · npm

GHSA-72hp-qff8-4pvv Parse Server has a protected fields bypass via logical query operators

HIGH Published 2026-03-11 Modified 2026-03-11 Official page ↗
Aliases
CVE-2026-30962
Ecosystem
npm
Packages
parse-server
Severity
High
CVSS vector
CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:H/VI:N/VA:N/SC:N/SI:N/SA:N
Weaknesses
CWE-284
Reviewed
2026-03-11

Affected packages

• npm parse-server: >= 9.0.0, < 9.5.2-alpha.6 → fixed in 9.5.2-alpha.6 • npm parse-server: < 8.6.19 → fixed in 8.6.19

Description

Impact The validation for protected fields only checks top-level query keys. By wrapping a query constraint on a protected field inside a logical operator, the check is bypassed entirely. This allows any authenticated user to query on protected fields to extract field values. All Parse Server deployments have default protected fields and are vulnerable. Patches The fix adds recursive validation of sub-queries with logical operators, consistent with the existing recursive validation patterns. Workarounds Use a `beforeFind` trigger on affected classes to manually inspect the query for protected field references in logical operator sub-queries and reject the request. References • GitHub security advisory: https://github.com/parse-community/parse-server/security/advisories/GHSA-72hp-qff8-4pvv • Fix Parse Server 9: https://github.com/parse-community/parse-server/releases/tag/9.5.2-alpha.6 • Fix Parse Server 8: https://github.com/parse-community/parse-server/releases/tag/8.6.19

Related

Alias · CVE (1)

  • CVE-2026-30962 Parse Server is an open source backend that can be deployed to any infrastructure that can run Node.js. vulnerability

Weakness · CWE (1)

  • CWE-284 Improper Access Control weakness

References