GitHub Advisoryadvisory · Go
GHSA-72qv-j8vr-xvfv Mattermost Fails to Enforce MFA on Plugin Endpoints
HIGH
Official page ↗
- Aliases
- CVE-2025-25068
- Ecosystem
- Go
- Packages
- github.com/mattermost/mattermost/server/v8
- Severity
- High
- CVSS vector
- CVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:U/C:H/I:H/A:H
- Weaknesses
- CWE-306
- Reviewed
- 2025-03-21
Affected packages
• Go github.com/mattermost/mattermost/server/v8: >= 10.4.0, < 10.4.3 → fixed in 10.4.3
• Go github.com/mattermost/mattermost/server/v8: >= 10.3.0, < 10.3.4 → fixed in 10.3.4
• Go github.com/mattermost/mattermost/server/v8: >= 9.11.0, < 9.11.9 → fixed in 9.11.9
• Go github.com/mattermost/mattermost/server/v8: >= 10.5.0, < 10.5.1 → fixed in 10.5.1
Description
Mattermost versions 10.4.x <= 10.4.2, 10.3.x <= 10.3.3, 9.11.x <= 9.11.8, 10.5.x <= 10.5.0 fail to enforce MFA on plugin endpoints, which allows authenticated attackers to bypass MFA protections via API requests to plugin-specific routes.
Related
Alias · CVE (1)
- CVE-2025-25068 Mattermost versions 10.4.x <= 10.4.2, 10.3.x <= 10.3.3, 9.11.x <= 9.11.8, 10.5.x <= 10.5.0 fail to enforce MFA on plugin endpoints, which… vulnerability
Weakness · CWE (1)
- CWE-306 Missing Authentication for Critical Functionality weakness