GitHub Advisoryadvisory · Packagist

GHSA-72w2-j52c-7682 Moodle SQL Injection vulnerability

HIGH Published 2023-03-23 Modified 2024-04-19 Official page ↗
Aliases
CVE-2023-28329
Ecosystem
Packagist
Packages
moodle/moodle
Severity
High
CVSS vector
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
Weaknesses
CWE-89
Reviewed
2023-03-23

Affected packages

• Packagist moodle/moodle: >= 4.1.0, < 4.1.2 → fixed in 4.1.2 • Packagist moodle/moodle: >= 4.0.0, < 4.0.7 → fixed in 4.0.7 • Packagist moodle/moodle: >= 3.11.0, < 3.11.13 → fixed in 3.11.13 • Packagist moodle/moodle: < 3.9.20 → fixed in 3.9.20

Description

Insufficient validation of profile field availability condition resulted in an SQL injection risk (by default only available to teachers and managers).

Related

Alias · CVE (1)

  • CVE-2023-28329 Insufficient validation of profile field availability condition resulted in an SQL injection risk (by default only available to teachers… vulnerability

Weakness · CWE (1)

  • CWE-89 Improper Neutralization of Special Elements used in an SQL Command weakness

References