GitHub Advisoryadvisory · Maven, RubyGems

GHSA-735f-pc8j-v9w8 protobuf-java has potential Denial of Service issue

HIGH Published 2024-09-19 Modified 2025-09-10 Official page ↗
Aliases
CVE-2024-7254
Ecosystem
Maven, RubyGems
Packages
com.google.protobuf:protobuf-java, com.google.protobuf:protobuf-javalite, com.google.protobuf:protobuf-kotlin, com.google.protobuf:protobuf-kotlin-lite, google-protobuf
Severity
High
CVSS vector
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
Weaknesses
CWE-20, CWE-400, CWE-787
Reviewed
2024-09-19

Affected packages

• Maven com.google.protobuf:protobuf-java: < 3.25.5 → fixed in 3.25.5 • Maven com.google.protobuf:protobuf-javalite: < 3.25.5 → fixed in 3.25.5 • Maven com.google.protobuf:protobuf-kotlin: < 3.25.5 → fixed in 3.25.5 • Maven com.google.protobuf:protobuf-kotlin-lite: < 3.25.5 → fixed in 3.25.5 • RubyGems google-protobuf: < 3.25.5 → fixed in 3.25.5 • RubyGems google-protobuf: >= 4.0.0.rc.1, < 4.27.5 → fixed in 4.27.5 • RubyGems google-protobuf: >= 4.28.0.rc.1, < 4.28.2 → fixed in 4.28.2 • Maven com.google.protobuf:protobuf-kotlin-lite: >= 4.0.0-RC1, < 4.27.5 → fixed in 4.27.5 • Maven com.google.protobuf:protobuf-kotlin-lite: >= 4.28.0-RC1, < 4.28.2 → fixed in 4.28.2 • Maven com.google.protobuf:protobuf-kotlin: >= 4.0.0-RC1, < 4.27.5 → fixed in 4.27.5 • Maven com.google.protobuf:protobuf-kotlin: >= 4.28.0-RC1, < 4.28.2 → fixed in 4.28.2 • Maven com.google.protobuf:protobuf-javalite: >= 4.0.0-RC1, < 4.27.5 → fixed in 4.27.5 • Maven com.google.protobuf:protobuf-javalite: >= 4.28.0-RC1, < 4.28.2 → fixed in 4.28.2 • Maven com.google.protobuf:protobuf-java: >= 4.0.0-RC1, < 4.27.5 → fixed in 4.27.5 • Maven com.google.protobuf:protobuf-java: >= 4.28.0-RC1, < 4.28.2 → fixed in 4.28.2

Description

Summary When parsing unknown fields in the Protobuf Java Lite and Full library, a maliciously crafted message can cause a StackOverflow error and lead to a program crash. Reporter: Alexis Challande, Trail of Bits Ecosystem Security Team Affected versions: This issue affects all versions of both the Java full and lite Protobuf runtimes, as well as Protobuf for Kotlin and JRuby, which themselves use the Java Protobuf runtime. Severity CVE-2024-7254 High CVSS4.0 Score 8.7 (NOTE: there may be a delay in publication) This is a potential Denial of Service. Parsing nested groups as unknown fields with DiscardUnknownFieldsParser or Java Protobuf Lite parser, or against Protobuf map fields, creates unbounded recursions that can be abused by an attacker. Proof of Concept For reproduction details, please refer to the unit tests (Protobuf Java LiteTest and CodedInputStreamTest) that identify the specific inputs that exercise this parsing weakness. Remediation and Mitigation We have been working diligently to address this issue and have released a mitigation that is available now. Please update to the latest available versions of the following packages: • protobuf-java (3.25.5, 4.27.5, 4.28.2) • protobuf-javalite (3.25.5, 4.27.5, 4.28.2) • protobuf-kotlin (3.25.5, 4.27.5, 4.28.2) • protobuf-kotlin-lite (3.25.5, 4.27.5, 4.28.2) • com-protobuf [JRuby gem only] (3.25.5, 4.27.5, 4.28.2)

Related

Alias · CVE (1)

  • CVE-2024-7254 Any project that parses untrusted Protocol Buffers data containing an arbitrary number of nested groups / series of SGROUP tags can… vulnerability

Weakness · CWE (3)

  • CWE-20 Improper Input Validation weakness
  • CWE-400 Uncontrolled Resource Consumption weakness
  • CWE-787 Out-of-bounds Write weakness

References