GitHub Advisoryadvisory · npm
GHSA-7375-vjr2-3g7w Cross-Site Scripting in glance
MEDIUM
Official page ↗
- Aliases
- CVE-2018-3748
- Ecosystem
- npm
- Packages
- glance
- Severity
- Moderate
- CVSS vector
- CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N
- Weaknesses
- CWE-79
- Reviewed
- 2020-06-16
Affected packages
• npm glance: < 3.0.8 → fixed in 3.0.8
Description
Versions of `glance` before 3.0.8 are vulnerable to Stored Cross-Site Scripting (XSS). This is only exploitable if the attacker is able to control the name of a file that is served by the `glance` package.
Related
Alias · CVE (1)
- CVE-2018-3748 There is a Stored XSS vulnerability in the glance node module versions <= 3.0.5. vulnerability
Weakness · CWE (1)
- CWE-79 Improper Neutralization of Input During Web Page Generation weakness
References
- https://nvd.nist.gov/vuln/detail/CVE-2018-3748 advisory
- https://github.com/jarofghosts/glance/commit/cdc68bb68d785343ddb829f1adc130cdd6169533 web
- https://hackerone.com/reports/310133 web
- https://github.com/advisories/GHSA-7375-vjr2-3g7w advisory
- https://github.com/jarofghosts/glance package
- https://www.npmjs.com/advisories/610 web