GitHub Advisoryadvisory · Maven

GHSA-7382-fv7p-v9v3 Apache Continuum and Archiva vulnerable to Cross-site Scripting

MEDIUM Published 2022-05-14 Modified 2025-04-12 Official page ↗
Aliases
CVE-2011-0533
Ecosystem
Maven
Packages
org.apache.archiva:archiva, org.apache.continuum:continuum
Severity
Moderate
Weaknesses
CWE-79
Reviewed
2025-04-12

Affected packages

• Maven org.apache.archiva:archiva: >= 1.0, < 1.3.4 → fixed in 1.3.4 • Maven org.apache.continuum:continuum: >= 1.1, < 1.3.7 → fixed in 1.3.7 • Maven org.apache.continuum:continuum: 1.4.0-beta (no fix yet)

Description

Cross-site scripting (XSS) vulnerability in Apache Continuum 1.1 through 1.2.3.1, 1.3.6, and 1.4.0 Beta; and Archiva 1.3.0 through 1.3.3 and 1.0 through 1.2.2 allows remote attackers to inject arbitrary web script or HTML via a crafted parameter, related to the autoIncludeParameters setting for the extremecomponents table.

Related

Alias · CVE (1)

  • CVE-2011-0533 Cross-site scripting (XSS) vulnerability in Apache Continuum 1.1 through 1.2.3.1, 1.3.6, and 1.4.0 Beta; and Archiva 1.3.0 through 1.3.3… vulnerability

Weakness · CWE (1)

  • CWE-79 Improper Neutralization of Input During Web Page Generation weakness

References