GitHub Advisoryadvisory · npm

GHSA-73jp-3c67-hjfv Authentication Bypass in passport-azure-ad

HIGH Published 2018-07-26 Modified 2021-09-02 Official page ↗
Aliases
CVE-2016-7191
Ecosystem
npm
Packages
passport-azure-ad
Severity
High
CVSS vector
CVSS:3.0/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H
Weaknesses
CWE-287
Reviewed
2020-06-16

Affected packages

• npm passport-azure-ad: >= 1.0.0, < 1.4.6 → fixed in 1.4.6 • npm passport-azure-ad: >= 2.0.0, < 2.0.1 → fixed in 2.0.1

Description

Affected versions of `passport-azure-ad` do not recognize the `validateIssuer` setting, which allows remote attackers to bypass authentication via a crafted token. Recommendation Version 1.x: Update to version 1.4.6 or later. Version 2.x: Update to version 2.0.1 or later.

Related

Alias · CVE (1)

  • CVE-2016-7191 The Microsoft Azure Active Directory Passport (aka Passport-Azure-AD) library 1.x before 1.4.6 and 2.x before 2.0.1 for Node.js does not… vulnerability

Weakness · CWE (1)

  • CWE-287 Improper Authentication weakness

References