GitHub Advisoryadvisory · npm
GHSA-73v8-v6g4-vrpm Arbitrary File Overwrite in decompress-zip
HIGH
Official page ↗
- Ecosystem
- npm
- Packages
- decompress-zip
- Severity
- High
- Reviewed
- 2020-08-31
Affected packages
• npm decompress-zip: < 0.2.2 → fixed in 0.2.2
• npm decompress-zip: >= 0.3.0, < 0.3.2 → fixed in 0.3.2
Description
Vulnerable versions of `decompress-zip` are affected by the Zip-Slip vulnerability, an arbitrary file write vulnerability. The vulnerability occurs because `decompress-zip` does not verify that extracted files do not resolve to targets outside of the extraction root directory.
Recommendation
For `decompress-zip` 0.2.x upgrade to 0.2.2 or later.
For `decompress-zip` 0.3.x upgrade to 0.3.2 or later.