GitHub Advisoryadvisory · RubyGems

GHSA-73w7-6w9g-gc8w RubyGems has Origin Validation Error vulnerability

HIGH Published 2022-05-13 Modified 2023-03-09 Official page ↗
Aliases
CVE-2017-0902
Ecosystem
RubyGems
Packages
rubygems-update
Severity
High
CVSS vector
CVSS:3.0/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H
Weaknesses
CWE-346, CWE-350
Reviewed
2023-03-09

Affected packages

• RubyGems rubygems-update: < 2.6.13 → fixed in 2.6.13

Description

RubyGems version 2.6.12 and earlier is vulnerable to a DNS hijacking vulnerability that allows a MITM attacker to force the RubyGems client to download and install gems from a server that the attacker controls.

Related

Alias · CVE (1)

  • CVE-2017-0902 RubyGems version 2.6.12 and earlier is vulnerable to a DNS hijacking vulnerability that allows a MITM attacker to force the RubyGems client… vulnerability

Weakness · CWE (2)

  • CWE-346 Origin Validation Error weakness
  • CWE-350 Reliance on Reverse DNS Resolution for a Security-Critical Action weakness

References