GitHub Advisoryadvisory · PyPI

GHSA-74vq-h4q8-x6jv Ansible Path Traversal vulnerability

LOW Published 2019-04-15 Modified 2024-11-18 Official page ↗
Aliases
CVE-2019-3828
Ecosystem
PyPI
Packages
ansible
Severity
Low
CVSS vector
CVSS:3.1/AV:L/AC:L/PR:H/UI:R/S:C/C:L/I:L/A:N
Weaknesses
CWE-22
Reviewed
2020-06-16

Affected packages

• PyPI ansible: < 2.5.15 → fixed in 2.5.15 • PyPI ansible: >= 2.6.0a1, < 2.6.14 → fixed in 2.6.14 • PyPI ansible: >= 2.7.0a1, < 2.7.8 → fixed in 2.7.8

Description

Ansible fetch module before versions 2.5.15, 2.6.14, 2.7.8 has a path traversal vulnerability which allows copying and overwriting files outside of the specified destination in the local ansible controller host, by not restricting an absolute path.

Related

Alias · CVE (1)

  • CVE-2019-3828 Ansible fetch module before versions 2.5.15, 2.6.14, 2.7.8 has a path traversal vulnerability which allows copying and overwriting files… vulnerability

Weakness · CWE (1)

  • CWE-22 Improper Limitation of a Pathname to a Restricted Directory weakness

References