GitHub Advisoryadvisory · PyPI
GHSA-7527-8855-9cf8 Incorrect header handling in mod-wsgi
HIGH
Official page ↗
- Aliases
- CVE-2022-2255
- Ecosystem
- PyPI
- Packages
- mod-wsgi
- Severity
- High
- CVSS vector
- CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:N
- Weaknesses
- CWE-345
- Reviewed
- 2022-08-30
Affected packages
• PyPI mod-wsgi: < 4.9.3 → fixed in 4.9.3
Description
A vulnerability was found in mod_wsgi. The X-Client-IP header is not removed from a request from an untrusted proxy, allowing an attacker to pass the X-Client-IP header to the target WSGI application because the condition to remove it is missing.
Related
Alias · CVE (1)
- CVE-2022-2255 A vulnerability was found in mod_wsgi. vulnerability
Weakness · CWE (1)
- CWE-345 Insufficient Verification of Data Authenticity weakness
References
- https://nvd.nist.gov/vuln/detail/CVE-2022-2255 advisory
- https://github.com/GrahamDumpleton/mod_wsgi/commit/af3c0c2736bc0b0b01fa0f0aad3c904b7fa9c751 web
- https://github.com/GrahamDumpleton/mod_wsgi package
- https://github.com/GrahamDumpleton/mod_wsgi/blob/4.9.2/src/server/mod_wsgi.c#L13940-L13941 web
- https://github.com/GrahamDumpleton/mod_wsgi/blob/4.9.2/src/server/mod_wsgi.c#L14046-L14082 web
- https://github.com/pypa/advisory-database/tree/main/vulns/mod-wsgi/PYSEC-2022-254.yaml web
- https://lists.debian.org/debian-lts-announce/2022/09/msg00021.html web
- https://modwsgi.readthedocs.io/en/latest/release-notes/version-4.9.3.html web