GitHub Advisoryadvisory · Packagist

GHSA-75c6-xqwr-v2r9 Moodle cross-site scripting (XSS) vulnerability

LOW Published 2022-05-13 Modified 2024-01-24 Official page ↗
Aliases
CVE-2014-2571
Ecosystem
Packagist
Packages
moodle/moodle
Severity
Low
Weaknesses
CWE-79
Reviewed
2024-01-24

Affected packages

• Packagist moodle/moodle: < 2.4.9 → fixed in 2.4.9 • Packagist moodle/moodle: >= 2.5.0, < 2.5.5 → fixed in 2.5.5 • Packagist moodle/moodle: >= 2.6.0, < 2.6.2 → fixed in 2.6.2

Description

Cross-site scripting (XSS) vulnerability in the quiz_question_tostring function in mod/quiz/editlib.php in Moodle through 2.3.11, 2.4.x before 2.4.9, 2.5.x before 2.5.5, and 2.6.x before 2.6.2 allows remote authenticated users to inject arbitrary web script or HTML via a quiz question.

Related

Alias · CVE (1)

  • CVE-2014-2571 Cross-site scripting (XSS) vulnerability in the quiz_question_tostring function in mod/quiz/editlib.php in Moodle through 2.3.11, 2.4.x… vulnerability

Weakness · CWE (1)

  • CWE-79 Improper Neutralization of Input During Web Page Generation weakness

References