GitHub Advisoryadvisory · PyPI

GHSA-75cw-5cgv-g853 IPython Notebook vulnerable to improper validation of the origin of websocket requests

HIGH Published 2022-05-14 Modified 2024-09-23 Official page ↗
Aliases
CVE-2014-3429
Ecosystem
PyPI
Packages
ipython
Severity
High
CVSS vector
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
Weaknesses
CWE-94
Reviewed
2024-04-29

Affected packages

• PyPI ipython: >= 0.12, < 1.2.0 → fixed in 1.2.0

Description

IPython Notebook 0.12 through 1.x before 1.2.0 does not validate the origin of websocket requests, which allows remote attackers to execute arbitrary code by leveraging knowledge of the kernel id and a crafted page.

Related

Alias · CVE (1)

  • CVE-2014-3429 IPython Notebook 0.12 through 1.x before 1.2 does not validate the origin of websocket requests, which allows remote attackers to execute… vulnerability

Weakness · CWE (1)

  • CWE-94 Improper Control of Generation of Code weakness

References