GitHub Advisoryadvisory · RubyGems

GHSA-75w6-p6mg-vh8j Rails actionpack gem vulnerable to Cross-site Scripting

MEDIUM Published 2017-10-24 Modified 2023-05-26 Official page ↗
Aliases
CVE-2011-0446
Ecosystem
RubyGems
Packages
actionpack, actionview
Severity
Moderate
Weaknesses
CWE-79
Reviewed
2020-06-16

Affected packages

• RubyGems actionpack: < 2.3.11 → fixed in 2.3.11 • RubyGems actionpack: >= 3.0.0, < 3.0.4 → fixed in 3.0.4 • RubyGems actionview: < 2.3.11 → fixed in 2.3.11 • RubyGems actionview: >= 3.0.0, < 3.0.4 → fixed in 3.0.4

Description

Multiple cross-site scripting (XSS) vulnerabilities in the `mail_to` helper in Ruby on Rails before 2.3.11, and 3.x before 3.0.4, when javascript encoding is used, allow remote attackers to inject arbitrary web script or HTML via a crafted (1) name or (2) email value.

Related

Alias · CVE (1)

  • CVE-2011-0446 Multiple cross-site scripting (XSS) vulnerabilities in the mail_to helper in Ruby on Rails before 2.3.11, and 3.x before 3.0.4, when… vulnerability

Weakness · CWE (1)

  • CWE-79 Improper Neutralization of Input During Web Page Generation weakness

References