GitHub Advisoryadvisory · RubyGems
GHSA-7627-mp87-jf6q Command injection in cocoapods-downloader
HIGH
Official page ↗
- Aliases
- CVE-2022-24440
- Ecosystem
- RubyGems
- Packages
- cocoapods-downloader
- Severity
- High
- CVSS vector
- CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H
- Weaknesses
- CWE-74, CWE-88
- Reviewed
- 2022-04-04
Affected packages
• RubyGems cocoapods-downloader: < 1.6.0 → fixed in 1.6.0
• RubyGems cocoapods-downloader: >= 1.6.2, < 1.6.3 → fixed in 1.6.3
Description
The package cocoapods-downloader before 1.6.0, from 1.6.2 and before 1.6.3 are vulnerable to Command Injection via git argument injection. When calling the Pod::Downloader.preprocess_options function and using git, both the git and branch parameters are passed to the git ls-remote subcommand in a way that additional flags can be set. The additional flags can be used to perform a command injection.
Related
Alias · CVE (1)
- CVE-2022-24440 The package cocoapods-downloader before 1.6.0, from 1.6.2 and before 1.6.3 are vulnerable to Command Injection via git argument injection. vulnerability
References
- https://nvd.nist.gov/vuln/detail/CVE-2022-24440 advisory
- https://github.com/CocoaPods/cocoapods-downloader/pull/124 web
- https://github.com/CocoaPods/cocoapods-downloader/pull/128 web
- https://github.com/CocoaPods/cocoapods-downloader/commit/52a0d54464932a90ded5a59c71a016e8dec0ca84 web
- https://github.com/CocoaPods/cocoapods-downloader/commit/b70bc39c75645aa6d4a01a3ca6de40477c84f4b5 web
- https://github.com/CocoaPods/cocoapods-downloader package
- https://github.com/rubysec/ruby-advisory-db/blob/master/gems/cocoapods-downloader/CVE-2022-24440.yml web
- https://snyk.io/vuln/SNYK-RUBY-COCOAPODSDOWNLOADER-2414278 web