GitHub Advisoryadvisory · Maven
GHSA-76q7-r3g4-wvm4 Sandbox bypass vulnerability in Jenkins Script Security Plugin
MEDIUM
Official page ↗
- Aliases
- CVE-2019-10400
- Ecosystem
- Maven
- Packages
- org.jenkins-ci.plugins:script-security
- Severity
- Moderate
- CVSS vector
- CVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:U/C:L/I:L/A:N
- Reviewed
- 2023-12-14
Affected packages
• Maven org.jenkins-ci.plugins:script-security: < 1.63 → fixed in 1.63
Description
A sandbox bypass vulnerability in Jenkins Script Security Plugin 1.62 and earlier related to the handling of subexpressions in increment and decrement expressions not involving actual assignment allowed attackers to execute arbitrary code in sandboxed scripts.
Related
Alias · CVE (1)
- CVE-2019-10400 A sandbox bypass vulnerability in Jenkins Script Security Plugin 1.62 and earlier related to the handling of subexpressions in increment… vulnerability
References
- https://nvd.nist.gov/vuln/detail/CVE-2019-10400 advisory
- https://github.com/jenkinsci/script-security-plugin/commit/b28e4dc5584ef6515aeb9bc834691176546d0689 web
- https://github.com/jenkinsci/script-security-plugin package
- https://jenkins.io/security/advisory/2019-09-12/#SECURITY-1538 web
- http://www.openwall.com/lists/oss-security/2019/09/12/2 web