GitHub Advisoryadvisory · RubyGems

GHSA-76wm-422q-92mq Code injection in RubyGems

HIGH Published 2019-06-20 Modified 2021-08-17 Official page ↗
Aliases
CVE-2019-8324
Ecosystem
RubyGems
Packages
rubygems-update
Severity
High
CVSS vector
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
Weaknesses
CWE-94
Reviewed
2019-06-20

Affected packages

• RubyGems rubygems-update: >= 2.6.0, < 2.7.9 → fixed in 2.7.9 • RubyGems rubygems-update: >= 3.0.0, < 3.0.2 → fixed in 3.0.2

Description

An issue was discovered in RubyGems 2.6 and later through 3.0.2. A crafted gem with a multi-line name is not handled correctly. Therefore, an attacker could inject arbitrary code to the stub line of gemspec, which is eval-ed by code in ensure_loadable_spec during the preinstall check.

Related

Alias · CVE (1)

  • CVE-2019-8324 An issue was discovered in RubyGems 2.6 and later through 3.0.2. vulnerability

Weakness · CWE (1)

  • CWE-94 Improper Control of Generation of Code weakness

References