GitHub Advisoryadvisory · RubyGems

GHSA-76wq-xw4h-f8wj activerecord vulnerable to SQL Injection

HIGH Published 2017-10-24 Modified 2025-01-21 Official page ↗
Aliases
CVE-2012-2695
Ecosystem
RubyGems
Packages
activerecord
Severity
High
Weaknesses
CWE-89
Reviewed
2020-06-16

Affected packages

• RubyGems activerecord: >= 3.0.0.beta, < 3.0.14 → fixed in 3.0.14 • RubyGems activerecord: >= 3.1.0, < 3.1.6 → fixed in 3.1.6 • RubyGems activerecord: >= 3.2.0, < 3.2.6 → fixed in 3.2.6 • RubyGems activerecord: < 2.3.15 → fixed in 2.3.15

Description

The Active Record component in Ruby on Rails efore 2.3.15, 3.0.x before 3.0.14, 3.1.x before 3.1.6, and 3.2.x before 3.2.6 does not properly implement the passing of request data to a where method in an ActiveRecord class, which allows remote attackers to conduct certain SQL injection attacks via nested query parameters that leverage improper handling of nested hashes, a related issue to CVE-2012-2661.

Related

Alias · CVE (1)

  • CVE-2012-2695 The Active Record component in Ruby on Rails before 3.0.14, 3.1.x before 3.1.6, and 3.2.x before 3.2.6 does not properly implement the… vulnerability

Weakness · CWE (1)

  • CWE-89 Improper Neutralization of Special Elements used in an SQL Command weakness

References