GitHub Advisoryadvisory · npm
GHSA-7752-f4gf-94gc Materialize-css vulnerable to Cross-site Scripting in autocomplete component
MEDIUM
Official page ↗
- Aliases
- CVE-2019-11003
- Ecosystem
- npm
- Packages
- materialize-css, @materializecss/materialize
- Severity
- Moderate
- CVSS vector
- CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N
- Weaknesses
- CWE-79
- Reviewed
- 2020-06-16
Affected packages
• npm materialize-css: <= 1.0.0 (no fix yet)
• npm @materializecss/materialize: < 1.1.0-alpha → fixed in 1.1.0-alpha
Description
All versions of `materialize-css` are vulnerable to Cross-Site Scripting. The `autocomplete` component does not sufficiently sanitize user input, allowing an attacker to execute arbitrary JavaScript code if the malicious input is rendered by a user.
Recommendation
No fix is currently available. Consider using an alternative module until a fix is made available.
Related
Alias · CVE (1)
- CVE-2019-11003 In Materialize through 1.0.0, XSS is possible via the Autocomplete feature. vulnerability
Weakness · CWE (1)
- CWE-79 Improper Neutralization of Input During Web Page Generation weakness