GitHub Advisoryadvisory · npm

GHSA-77c7-pq4r-6mcq degit has a Command Injection issue

HIGH Published 2026-06-09 Modified 2026-07-30 Official page ↗
Aliases
CVE-2026-11572
Ecosystem
npm
Packages
degit
Severity
High
CVSS vector
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
Weaknesses
CWE-77, CWE-78
Reviewed
2026-07-30

Affected packages

• npm degit: < 2.8.6 → fixed in 2.8.6 • npm degit: >= 3.0.0, < 3.3.1 → fixed in 3.3.1

Description

Versions of the package degit before 2.8.6, from 3.0.0 and before 3.3.1 are vulnerable to Command Injection due to improper sanitisation of user input for git shell commands directly invoked with exec() method by _cloneWithGit() and fetchRefs() functions. An attacker can execute arbitrary operating system commands as the process user by supplying a specially crafted git repository name.

Related

Alias · CVE (1)

  • CVE-2026-11572 Versions of the package degit before 2.8.6, from 3.0.0 and before 3.3.1 are vulnerable to Command Injection due to improper sanitisation of… vulnerability

Weakness · CWE (2)

  • CWE-77 Improper Neutralization of Special Elements used in a Command weakness
  • CWE-78 Improper Neutralization of Special Elements used in an OS Command weakness

References