GitHub Advisoryadvisory · npm

GHSA-77jf-fjjf-xcww Invalid Curve Attack in openpgp

MEDIUM Published 2019-08-23 Modified 2021-07-27 Official page ↗
Aliases
CVE-2019-9155
Ecosystem
npm
Packages
openpgp
Severity
Moderate
CVSS vector
CVSS:3.0/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:N/A:N
Weaknesses
CWE-327
Reviewed
2019-08-23

Affected packages

• npm openpgp: < 4.3.0 → fixed in 4.3.0

Description

Versions of `openpgp` prior to 4.3.0 are vulnerable to an Invalid Curve Attack. The package's implementation of ECDH fails to verify the validity of the communication partner's public key. The package calculates the resulting key secret based on an altered curve instead of the specified elliptic curve. Attackers may exfiltrate the victim's private key by choosing the altered curve. An attack requires the attacker being able to initiate message decryption and record the result. Furthermore the victim's key must offer an ECDH public key. Recommendation Upgrade to version 4.3.0 or later. If you are upgrading from a version <4.0.0 it is highly recommended to read the `High-Level API Changes` section of the `openpgp` 4.0.0 release: https://github.com/openpgpjs/openpgpjs/releases/tag/v4.0.0

Related

Alias · CVE (1)

  • CVE-2019-9155 A cryptographic issue in OpenPGP.js <=4.2.0 allows an attacker who is able provide forged messages and gain feedback about whether… vulnerability

Weakness · CWE (1)

  • CWE-327 Use of a Broken or Risky Cryptographic Algorithm weakness

References