GitHub Advisoryadvisory · Packagist
GHSA-786g-xv8v-9h93 Moodle Cross-site Scripting vulnerability
MEDIUM
Official page ↗
- Aliases
- CVE-2021-36398
- Ecosystem
- Packagist
- Packages
- moodle/moodle
- Severity
- Moderate
- CVSS vector
- CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N
- Weaknesses
- CWE-79
- Reviewed
- 2023-03-08
Affected packages
• Packagist moodle/moodle: >= 3.11, < 3.11.1 → fixed in 3.11.1
Description
In Moodle, ID numbers displayed in the web service token list required additional sanitizing to prevent a stored XSS risk.
Related
Alias · CVE (1)
- CVE-2021-36398 In moodle, ID numbers displayed in the web service token list required additional sanitizing to prevent a stored XSS risk. vulnerability
Weakness · CWE (1)
- CWE-79 Improper Neutralization of Input During Web Page Generation weakness