GitHub Advisoryadvisory · npm

GHSA-7889-rm5j-hpgg Clipboard feature vulnerability allowing to inject arbitrary HTML into the editor using paste functionality

MEDIUM Published 2021-08-23 Modified 2022-02-08 Official page ↗
Aliases
CVE-2021-32809
Ecosystem
npm
Packages
ckeditor4
Severity
Moderate
CVSS vector
CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:U/C:L/I:L/A:N
Weaknesses
CWE-79, CWE-94
Reviewed
2021-08-23

Affected packages

• npm ckeditor4: >= 4.5.2, < 4.16.2 → fixed in 4.16.2

Description

Affected packages The vulnerability has been discovered in clipboard plugin. All plugins with clipboard plugin dependency are affected: • clipboard • pastetext • pastetools • widget • uploadwidget • autolink • tableselection Impact A potential vulnerability has been discovered in CKEditor 4 Clipboard package. The vulnerability allowed to abuse paste functionality using malformed HTML, which could result in injecting arbitrary HTML into the editor. It affects all users using the CKEditor 4 plugins listed above at version >= 4.5.2. Patches The problem has been recognized and patched. The fix will be available in version 4.16.2. For more information Email us at [email protected] if you have any questions or comments about this advisory. Acknowledgements The CKEditor 4 team would like to thank Anton Subbotin (skavans) for recognizing and reporting this vulnerability.

Related

Alias · CVE (1)

  • CVE-2021-32809 ckeditor is an open source WYSIWYG HTML editor with rich content support. vulnerability

Weakness · CWE (2)

  • CWE-79 Improper Neutralization of Input During Web Page Generation weakness
  • CWE-94 Improper Control of Generation of Code weakness

References