GitHub Advisoryadvisory · npm

GHSA-78j5-gcmf-vqc8 Cross-Site Scripting (XSS) in Verdaccio

MEDIUM Published 2019-05-29 Modified 2021-10-06 Official page ↗
Aliases
CVE-2019-14772
Ecosystem
npm
Packages
verdaccio
Severity
Moderate
CVSS vector
CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N
Weaknesses
CWE-79
Reviewed
2020-05-28

Affected packages

• npm verdaccio: < 3.12.0 → fixed in 3.12.0

Description

Impact What kind of vulnerability is it? Who is impacted? Cross-Site Scripting XSS, malicious packages with content Javascript that might be executed in the User Interface stealing user credentials. Patches Has the problem been patched? What versions should users upgrade to? Users that still using `v3` must upgrade to >3.12.0 or those have no problem to migrate to a major version >=4.0.0 also fix the issue. Workarounds Is there a way for users to fix or remediate the vulnerability without upgrading? No, the users must update. References Are there any links users can visit to find out more? https://www.npmjs.com/advisories/832 https://www.npmjs.com/advisories/833 The issue was reported by the NPMJS Security Team For more information If you have any questions or comments about this advisory: • Read the Security Policy to find the ways to be in contact with us.

Related

Alias · CVE (1)

Weakness · CWE (1)

  • CWE-79 Improper Neutralization of Input During Web Page Generation weakness

References