GitHub Advisoryadvisory · Maven
GHSA-78wr-2p64-hpwj Apache Commons IO: Possible denial of service attack on untrusted input to XmlStreamReader
HIGH
Official page ↗
- Aliases
- CVE-2024-47554
- Ecosystem
- Maven
- Packages
- commons-io:commons-io
- Severity
- High
- CVSS vector
- CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
- Weaknesses
- CWE-400
- Reviewed
- 2024-10-03
Affected packages
• Maven commons-io:commons-io: >= 2.0, < 2.14.0 → fixed in 2.14.0
Description
Uncontrolled Resource Consumption vulnerability in Apache Commons IO.
The `org.apache.commons.io.input.XmlStreamReader` class may excessively consume CPU resources when processing maliciously crafted input.
This issue affects Apache Commons IO: from 2.0 before 2.14.0.
Users are recommended to upgrade to version 2.14.0 or later, which fixes the issue.
Related
Alias · CVE (1)
- CVE-2024-47554 Uncontrolled Resource Consumption vulnerability in Apache Commons IO. vulnerability
Weakness · CWE (1)
- CWE-400 Uncontrolled Resource Consumption weakness