GitHub Advisoryadvisory · npm

GHSA-7942-2fx8-qhpf Raneto v0.17.0 employs weak password complexity requirements

CRITICAL Published 2022-08-05 Modified 2022-08-11 Official page ↗
Aliases
CVE-2022-35143
Ecosystem
npm
Packages
raneto
Severity
Critical
CVSS vector
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
Weaknesses
CWE-521
Reviewed
2022-08-11

Affected packages

• npm raneto: < 0.17.1 → fixed in 0.17.1

Description

Raneto v0.17.0 employs weak password complexity requirements, allowing attackers to crack user passwords via brute-force attacks. Version 0.17.1 contains security mitigations for this and other vulnerabilities.

Related

Alias · CVE (1)

  • CVE-2022-35143 Renato v0.17.0 employs weak password complexity requirements, allowing attackers to crack user passwords via brute-force attacks. vulnerability

Weakness · CWE (1)

  • CWE-521 Weak Password Requirements weakness

References