GitHub Advisoryadvisory · PyPI
GHSA-7944-h5rw-qmjx ZCatalog plug-in for Zope allows anonymous users to bypass access restrictions
HIGH
Official page ↗
- Aliases
- CVE-2002-0688
- Ecosystem
- PyPI
- Packages
- zope
- Severity
- High
- Reviewed
- 2024-02-12
Affected packages
• PyPI zope: >= 2.4.0, < 2.6.0 → fixed in 2.6.0
Description
ZCatalog plug-in index support capability for Zope 2.4.0 through 2.5.1 allows anonymous users and untrusted code to bypass access restrictions and call arbitrary methods of catalog indexes.
Related
Alias · CVE (1)
- CVE-2002-0688 ZCatalog plug-in index support capability for Zope 2.4.0 through 2.5.1 allows anonymous users and untrusted code to bypass access… vulnerability
References
- https://nvd.nist.gov/vuln/detail/CVE-2002-0688 advisory
- https://web.archive.org/web/20020810160608/http://www.zope.org/Products/Zope/Hotfix_2002-06-14/security_alert web
- https://web.archive.org/web/20020822025750/http://www.iss.net/security_center/static/9610.php web
- https://web.archive.org/web/20021206023914/http://rhn.redhat.com/errata/RHSA-2002-060.html web
- https://web.archive.org/web/20021223212650/http://online.securityfocus.com/bid/5812 web
- https://web.archive.org/web/20070430090648/http://www.debian.org/security/2004/dsa-490 web