GitHub Advisoryadvisory · PyPI

GHSA-79j6-g2m3-jgfw vLLM has remote code execution vulnerability in the tool call parser for Qwen3-Coder

HIGH Published 2025-08-21 Modified 2025-08-21 Official page ↗
Aliases
CVE-2025-9141
Ecosystem
PyPI
Packages
vllm
Severity
High
CVSS vector
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
Weaknesses
CWE-502
Reviewed
2025-08-21

Affected packages

• PyPI vllm: >= 0.10.0, < 0.10.1.1 → fixed in 0.10.1.1

Description

Summary An unsafe deserialization vulnerability allows any authenticated user to execute arbitrary code on the server if they are able to get the model to pass the code as an argument to a tool call. Details vLLM's Qwen3 Coder tool parser contains a code execution path that uses Python's `eval()` function to parse tool call parameters. This occurs during the parameter conversion process when the parser attempts to handle unknown data types. This code path is reached when: 1. Tool calling is enabled (`--enable-auto-tool-choice`) 2. The qwen3_coder parser is specified (`--tool-call-parser qwen3_coder`) 3. The parameter type is not explicitly defined or recognized Impact Remote Code Execution via Python's `eval()` function.

Related

Alias · not in database (1)

Weakness · CWE (1)

  • CWE-502 Deserialization of Untrusted Data weakness

References