GitHub Advisoryadvisory · Packagist
GHSA-79jw-2f46-wv22 Authenticated remote code execution in October CMS
HIGH
Official page ↗
- Aliases
- CVE-2022-21705
- Ecosystem
- Packagist
- Packages
- october/system
- Severity
- High
- CVSS vector
- CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:H/I:H/A:H
- Weaknesses
- CWE-74
- Reviewed
- 2022-02-23
Affected packages
• Packagist october/system: < 1.0.474 → fixed in 1.0.474
• Packagist october/system: >= 1.1.0, < 1.1.10 → fixed in 1.1.10
• Packagist october/system: >= 2.0.0, < 2.1.27 → fixed in 2.1.27
Description
Impact
An authenticated user with the permissions to create, modify and delete website pages can exploit this vulnerability to bypass `cms.safe_mode` / `cms.enableSafeMode` in order to execute arbitrary code.
• This issue only affects admin panels that rely on safe mode and restricted permissions.
• To exploit this vulnerability, an attacker must first have access to the backend area.
Patches
The issue has been patched in Build 474 (v1.0.474) and v1.1.10.
Workarounds
Apply https://github.com/octobercms/library/commit/c393c5ce9ca2c5acc3ed6c9bb0dab5ffd61965fe to your installation manually if unable to upgrade to Build 474 or v1.1.10.
References
Credits to:
• David Miller
For more information
If you have any questions or comments about this advisory:
• Email us at [email protected]
Related
Alias · CVE (1)
- CVE-2022-21705 Octobercms is a self-hosted CMS platform based on the Laravel PHP Framework. vulnerability
Weakness · CWE (1)
- CWE-74 Improper Neutralization of Special Elements in Output Used by a Downstream Component weakness